VMware addressed a critical remote code execution flaw, tracked as CVE-2021-21972, in vCenter Server virtual infrastructure management platform.

VMware has addressed a critical remote code execution (RCE) vulnerability in the vCenter Server virtual infrastructure management platform, tracked as CVE-2021-21972, that could be exploited by attackers to potentially take control of affected systems.

vCenter Server is the centralized management utility for VMware, and is used to manage virtual machines, multiple ESXi hosts, and all dependent components from a single centralized location.

The flaw could be exploited by remote, unauthenticated attackers without user interaction.

“The vSphere Client (HTML5) contains a remote code execution vulnerability in a vCenter Server plugin. VMware has evaluated the severity of this issue to be in the Critical severity range with a maximum CVSSv3 base score of 9.8.” reads the advisory published. “A malicious actor with network access to port 443 may exploit this issue to execute commands with unrestricted privileges on the underlying operating system that hosts vCenter Server. “

The CVE-2021-21972 issue was reported by Mikhail Klyuchnikov from Positive Technologies, it has received a CVSSv3 base score of 9.8/ 10 according to VMware’s security advisory.

The issue affects vCenter Server plugin for vROPs which is available in all default installations. vROPs does not need be present to have this endpoint available. The virtualization giant has provided workarounds to disable it.

The company recommends upgrading vulnerable vCenter Server installs to versions 6.5 U3n, 6.7 U3l, or 7.0 U1c as soon as possible.

VMware also provides step-by-step Workaround Instructions for CVE-2021-21972 and CVE-2021-21973 (KB82374 support document).

VMware also addressed an important heap-overflow flaw, tracked as CVE-2021-21974, in VMware ESXi. The issue can be exploited by attackers to execute arbitrary code remotely on vulnerable devices.

If you want to receive the weekly Security Affairs Newsletter for free subscribe here.

Pierluigi Paganini

(SecurityAffairs – hacking, VMWare)

The post VMware addresses a critical RCE issue in vCenter Server appeared first on Security Affairs.

By admin